未來函數檢測 | 推薦資源 | 熱門資源 收藏股海網 | 將股海網放到桌面
股海網,最好股票軟件下載中心,股票軟件,股票書籍,股票公式,股票知識,炒股教程
股海首頁 | 指標公式 | 分析軟件 | 行情軟件 | 數據軟件 | 資訊題材 | 工具應用 | 期貨基金 | 書籍教程 | 技術指標 | 股海絕技 | 外匯期貨 | 股票知識 |
股票軟件 大智慧 通達信 飛狐 東財通 操盤手 指南針 同花順 錢龍 券商軟件 手機炒股 和諧軟件 證券之星 金融界 分析家 數據下載 數據接口 期貨 基金 教程
股票公式 大智慧 通達信 飛狐 同花順 東財通 | 股票池 大智慧 通達信 | 股票書籍 | 指標分解 MACD BOLL KDJ OBV CCI RSI DMI SAR VOL DDX DDY DDZ WR CR
當前位置:→ 股海網 > 指標公式 > 通達信公式 > 正文
通達信乖離比主圖指標源碼
  • 相關簡介: 動態止損度:=5; 黑:=0;{下跌通道黑色K線開關} 離L:=0;{乖離提示開關} 提示:=0;{買賣文字提示開關} 布林M:=0;{開關} MMA:=0; 五:MA(CLOSE,5),COLORWHITE; 十:MA(CLOSE,10),COLOR00FFFF; M18:=MA(CLOSE,18),COLORRED; 離基:=五; 離O:=離基*1.20,COLOR555555; 離A:離基*1.15,COLOR555555; 離B:離基*1.10,COLOR555555; 離C:離基*0.
  • 文件大小: unknow
  • 瀏覽次數:
  • 運行環境:
  • 編輯發布: 股海網
  • 軟件來源: Internet
  • 加入時間: 2019/6/23 8:24:06
  • 解壓密碼: www.mfrjyw.live(請仔細輸入!復制無效!)
  • 下載統計:

股票軟件說明:

 

動態止損度:=5;
黑:=0;{下跌通道黑色K線開關}
離L:=0;{乖離提示開關}
提示:=0;{買賣文字提示開關}
布林M:=0;{開關}
MMA:=0;
五:MA(CLOSE,5),COLORWHITE;
十:MA(CLOSE,10),COLOR00FFFF;
M18:=MA(CLOSE,18),COLORRED;
離基:=五;
離O:=離基*1.20,COLOR555555;
離A:離基*1.15,COLOR555555;
離B:離基*1.10,COLOR555555;
離C:離基*0.90,COLOR555555;
離D:=離基*0.85,COLOR333333;
EXP50:=EXPMA(CLOSE,50),COLORGREEN;
MA30:MA(CLOSE,30),LINETHICK1,COLORRED;
MA60:MA(CLOSE,60),COLORGREEN;
β0:=(H-L)/2+L,LINETHICK0;
α:=β0,LINETHICK0;
β:=REF(β0,1),LINETHICK0,COLORGREEN;
γ:=REF(β0,2),LINETHICK0,COLORMAGENTA;
{漲:PLOYLINE(C>REF(C,1),CONST(C)),;
跌:PLOYLINE(C<REF(C,1),CONST(C)),COLOR00AA00,LINETHICK1;}
高:PLOYLINE(1,CONST(HHV(H,50))),COLOR770077,LINETHICK1;
低:=PLOYLINE(1,CONST(LLV(L,50))),COLOR777700,LINETHICK1;
中:=PLOYLINE(1,(高-低)/2+低),COLOR005555,LINETHICK4;
止損價:=CONST(HHV(C,5)*(100-動態止損度)/100);
止:PLOYLINE(CONST(C)<=止損價,止損價),COLOR888800,LINETHICK4;
DRAWTEXT(DYNAINFO(7)<=止損價 AND ISLASTBAR,止損價*1.05,'止損');
AA:=CLOSE/REF(C,1)>=1.09;
BA:=CLOSE/REF(C,1)>=1.09;
DRAWKLINE(H,O,L,C);
STICKLINE(AA,O,C,2.5,1),COLORYELLOW;
MA1:=MA(CLOSE,5),COLORRED;
MA2:=MA(CLOSE,10),COLORYELLOW;
MA3:=MA(CLOSE,20),COLOR770077;
E50:=EXPMA(CLOSE,50),LINETHICK1,POINTDOT,COLORLIGREEN;
E100:=EXPMA(CLOSE,100),POINTDOT,COLORGRAY;
MA181:MA(C,181),COLORGRAY;
{MA60:=MA(C,60),COLOR007700;}
{周:IF( MMA=1 ,MA2,DRAWNULL),COLORYELLOW,LINETHICK1;
月:IF( MMA=1 ,MA3,DRAWNULL),COLORWHITE,LINETHICK1;
季:IF( MMA=1 ,MA4,DRAWNULL),COLORGREEN,LINETHICK1;}
{IF(C>E50 ,E50,DRAWNULL),COLOR00FF00,LINETHICK1;}
IF(CONST(α>β) AND DYNAINFO(7)>0,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;
IF(CONST(α<=β)AND DYNAINFO(7)>0 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;
IF(CONST(α>β) AND DYNAINFO(7)>0 AND DYNAINFO(7)>=高*0.99,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;
IF(CONST(α<=β)AND DYNAINFO(7)>0 AND DYNAINFO(7)<=低*1.01 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;
N1:=12;
N2:=26;
N3:=9;
DIFF:=(EMA(CLOSE,N1) - EMA(CLOSE,N2));
DEA:=EMA(DIFF,N3);
MACD:=(2 * (DIFF - DEA));
MACD2:=MACD;
SARH:=CLOSE>SAR(4,2,20);
{IF(C<MA3 ,MA1,DRAWNULL),COLOR555555,LINETHICK1;}
{IF(C<MA3 ,MA2,DRAWNULL),COLOR222222,LINETHICK1;}
{IF(五>=REF(五,1) ,離A,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五>=REF(五,1) ,離B,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五<=REF(五,1) ,離C,DRAWNULL),COLOR00FF00,LINETHICK1;
IF(五<=REF(五,1) ,離D,DRAWNULL),COLOR00FF00,LINETHICK1;}
五V:=MA(V,5);
{IF(五V>=REF(五V,1) ,離A,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五V>=REF(五V,1) ,離B,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五V<=REF(五V,1) ,離C,DRAWNULL),COLOR00FF00,LINETHICK1;
IF(五V<=REF(五V,1) ,離D,DRAWNULL),COLOR00FF00,LINETHICK1;}
{IF(五<REF(五,2) AND 離L=0,離A,DRAWNULL),COLOR555555,LINETHICK1;
IF(五<REF(五,2) AND 離L=0,離D,DRAWNULL),COLOR555555,LINETHICK1;}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
STICKLINE(C<MA3 AND 黑=1,H,L,0,0),COLOR555555;
STICKLINE(MA1<MA3 AND 黑=1,O,C,2.5,1),COLOR555555;
STICKLINE(BA AND C<MA3,O,C,2.7,1),COLORWHITE;
{DRAWICON(MACD>REF(MACD,1) AND CROSS(C,MA3) AND 提示=0 ,L,1);}
{DRAWICON(REF(C>MA3 AND 提示,1) AND CROSS(MA(C,5),C),H,2);}
N:=14;
M:=6;
TRR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/TR;
MDI:=DMM*100/TR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
DMIJX:=CROSS(PDI,MDI) AND C>O ;
{STICKLINE(DMIJX,H,L,0,1),COLORYELLOW;
STICKLINE(DMIJX,O,C,2.7,0),COLORYELLOW;}
{DRAWICON(DMIJX AND 提示=0,L,1);}
{DRAWTEXT(H>離A,離A/0.99,'★'),COLORYELLOW;}
頭上邊:=MAX(O,C),NODRAW;
頭下邊:=MIN(O,C),NODRAW;
垂頭:=ABS(O-C),NODRAW;{垂頭}
長針:=(頭下邊-L),NODRAW;{長針}
垂:=長針/垂頭>2 AND (H-頭上邊)<=長針 AND L<REF(L,1) AND O<REF(C,1),NODRAW;
DRAWTEXT(垂 AND L<=LLV(L,3) AND L<離C AND 提示,L/1.01,'針') AND 提示,COLORGREEN,LINETHICK4;
DRAWTEXT(H>MA(CLOSE,5)*1.07 AND ISLASTBAR AND 提示,H*1.01,'離!'),COLORGREEN,LINETHICK2;
DRAWTEXT(L<MA(CLOSE,5)*1.005 AND L>MA(CLOSE,5) AND 提示=0 AND H<MA(CLOSE,5)*1.07 AND ISLASTBAR,L/1.02,'低吸'),COLORGREEN,LINETHICK2;
{////MACD反身向上////}
{MACD紅縮:=REF(MACD,1)>MACD AND MACD>0;
DRAWTEXT(REF(EVERY(MACD紅縮,3),1)
AND MACD>REF(MACD,1) AND C>MA(C,22) AND 提示=0,L/1.02,'啟動'),COLORWHITE;
}
{////MACD反身向上2////}
{MACD紅縮2:=REF(MACD,1)>MACD AND MACD>0;
DRAWTEXT(REF(EVERY(MACD紅縮2,2),1)
AND MACD>REF(MACD,1) AND C>MA(C,22) AND EVERY(DIFF>0,3) AND 提示=0,L/1.02,'起動'),COLORWHITE;
}
{突破買進(源碼)}
{DRAWTEXT(DYNAINFO(7)>0 AND ISLASTBAR ,HIGH,'("DYNAINFO(7)")');}
上5日:=REF(EVERY(C<MA1,2),1) AND CROSS(C,MA1);
STICKLINE(上5日,H,L,0,0),COLORFF00FF;
{STICKLINE(上5日,O,C,2.7,0),COLOR3366FF;}
STICKLINE(上5日,O,C,2.7,0),COLORFF00FF;
DRAWICON(上5日,L,1);
破5日:=REF(EVERY(C>MA1,4),1) AND CROSS(MA1,C);
DRAWICON(破5日,H,2);
DT:=REF(CLOSE/REF(C,1),1)<=0.95;
DRAWTEXT(AA AND DT AND CURRBARSCOUNT<60 ,H,'急挖坑'),COLORGREEN;
SC1:=MACD.MACD<0;
SC2:=CROSS(十,五);
SC3:=MA(V,5)<MA(V,10);
SC:=SC1 AND SC2 AND SC3 ;
DRAWTEXT(SC AND CURRBARSCOUNT<10 ,HHV(H,5),'三死叉'),COLORWHITE;
JC1:=MACD.MACD>0;
JC2:=CROSS(五,十);
JC3:=MA(V,5)>MA(V,10);
JC:=JC1 AND JC2 AND JC3 ;
DRAWTEXT(JC AND CURRBARSCOUNT<20 ,LLV(L,5),'后金叉'),COLORYELLOW;
{ZS:=CROSS(DMI.ADXR,DMI.ADX);
DRAWTEXT(ZS AND CURRBARSCOUNT<10 ,HHV(H,5),'轉勢'),COLORRED;}
{IF(五<REF(五,1),五,DRAWNULL),COLOR888888,LINETHICK1;};
{XQK:=H<REF(L,1) ;
DRAWTEXT(XQK AND CURRBARSCOUNT<20 ,H,'□□□□□□□□□□□□'),COLOR999999;
SQK:= L>REF(H,1);
DRAWTEXT(SQK AND CURRBARSCOUNT<20 ,L,'□□□□□□□□□□□□'),COLORRED;};
DRAWTEXT(CROSS(H,離B) AND CURRBARSCOUNT<10 ,HHV(H,3),'超乖離'),COLORYELLOW;
DRAWTEXT(CROSS(H,離A) AND CURRBARSCOUNT<10 ,HHV(H,3),'超乖離'),COLORYELLOW;
DRAWTEXT(CROSS(離C,L) AND CURRBARSCOUNT<10 ,LLV(L,3),'負乖離'),COLORWHITE;
DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2,HHV(H,5)*1.04,'MA5下'),COLORRED;
DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2 ,HHV(H,5)*1.01,'不持股'),COLORRED;


通達信乖離比主圖指標源碼

下載鏈接:(下載本站資源請點擊下面進入下載頁“藍色圖標”)
通達信乖離比主圖指標源碼下載
精品股票公式
福建快3走势